Connecting or networking a PC running Windows 7 Home Premium to a Mac running OS 10.4 (Tiger)

I recently upgraded from XP to Win7 and since I got everything working it’s been great. However, I had the hardest time connecting to my husband’s Mac (the files on which we both use for work). On XP it was relatively easy to network the two and Win7 promised it would be even easier, however in practice it just didn’t work and Googling the problem yielded very few helpful results. I have written here my specific problems and the solution I found. I hope this will help anyone who encounters the same problem to solve it in a lot less time than it took me.

This article assumes you have already enabled file sharing on the Mac in question and added it to the same workgroup as the PC (default in Win7: WORKGROUP).

The Mac appeared on the Network automatically and when I double clicked the icon it would pop up a username and password prompt. However, underneath the username field there was a path that said: PC COMPUTER NAME\mac-computer-name (indicating that it was somehow looking for the Mac within the PC, rather than on the network). This path was unchangeable wherever I looked. Even if I input the correct username & password for the Mac (those that had worked fine when connecting from XP), it would tell me it was the wrong username/password. All Google searches to fix similar problems would tell you to adjust advanced sharing settings in the “Local Security Policy”, however, this does not exist in Windows 7 Home Premium.

Trying to connect to other Macs on the network running a different OS (Leopard & Snow Leopard) was no problem. The specific problem only existed when trying to connect from the Windows 7 PC to the Mac runnning Tiger (OS 10.4).

What you need to do to fix the problem is edit the registry. Credit for this fix goes to a user on the Overclockers forum. I have given step by step instructions with pictures as editing the registry can be intimidating and it is not recommended if you don’t know exactly what to do.

Press Start, type ‘regedit’ (without quotations) and press enter:

The screen goes grey and a window pops up to ask you if you want to allow the program to make changes. Press yes. The registry editor will open:

Use the little triangles to expand the items as follows: HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > Control > Lsa. Make sure Lsa is selected (you can check the path at the bottom of the window to see whether you are in the right section). You should see a list of items displayed on the right (click to enlarge pic):

Right click inside that window on the right (at the bottom of the list) and select: New > DWORD (32-bit) Value

Enter ‘LmCompatibilityLevel’ (without quotations), then press enter:

Find the entry you have just added in the list (it should still be at the bottom where you added it, but if you don’t see it you can find it easily as the list is alphabetised), and double click it. In the box that pops up enter ‘2’ for Value data and leave the radio button on Hexadecimal (it is the default), press OK:

That is it! Now when you go back to Network, double click the icon of the Mac you were trying to connect to. Enter the user/password if applicable (in my exerience it only asks for this once, then it will remember it afterwards, big improvement on XP where you had to enter it every single time you wanted to connect) and you’ll be in!